Topic: App. closed: error: USER 76

Hi,
I have created flash lite 2.1 application and installer with swf2go. My application read and write sharedObject (local cache) while starting. One of my customer reports error <"Nokia E61i with Symbian OS">
after installation it says, App Closed: <someAppName> User 76.

Is there is any idea I can solve this?
I feel there is no problem with installer right? You have any idea what is User 76 error says in symbian OS/flash lite 2.1?

thanks

Re: App. closed: error: USER 76

hi,

does this error comes right after installing? or after installing and running the app first time from menu?

so far non of SWF2Go users have reported this error. it worked even on latest N95 and other S60 v3 devices.

also, it will help if you send me your application in SIS as well as in swf format.

best,

// chall3ng3r //

Re: App. closed: error: USER 76

This error is reported by one of my customer. This occurs after the successfull installation. When he try to run the installed app this error occurs.

Re: App. closed: error: USER 76

hi,

i found this in the S60 SDK docs, but not found any thread on forum nokia discussions.

76: This panic is raised by a call to the Remove() member function of a circular buffer, a CCirBuf when the number of items to be removed is zero or negative.

SWF2Go launcher don't use this function anywhere in the code. my guess is it is related to FL. you mentioned your application uses SO in startup. in FL2.1, it shows splash screen, and it might be the problem. so, in your FL app, you should try initializing SO after frame 1.

try this, andlet me know if it worked.

ciao,

// chall3ng3r //

Re: App. closed: error: USER 76

Hi,

I searched the web and eventually came to this forum. I am using Nokia N73 which is preinstalled with flash lite 1.1

As I wanted to run a phone theme that requires flash lite 2.1, I have successfully installed the flash 2.1 from adobe website to my symbian s60v3 in Nokia N73. The application flash 2.1 was successfully installed in my phone.

When I tried to run the swf phone theme, it managed to show a bit of the beginning and eventually closed itself and showed “ App. Closed: Flash USER 76”

I informed the creator of the phone theme about the problem but he said he have no idea about the error at all. He suggested that I tried to run the swf file on my PC. I did and the swf file works fine on the computer.

How can this error be solved? Any ideas?

Thanks.

Re: App. closed: error: USER 76

hi,

it seems a stange kind of error. and so far i am unable to find what is the cause of this error. my best guess is its somthing to do with FL and SO. when any FL application creates SO as soon as its started with FL, there's chance of this error. but i was unable to reproduce it on my side. so, its just a guess.

// chall3ng3r //

Re: App. closed: error: USER 76

Thanks. I am unable to find any other sites that discuss the error. I guess I'll just leave it there. Thanks again.