SWF2Go and Symbian S60 5th Edition

Update: SWF2Go Professional 2.5 is released which comes with built-in support for S60 5th Edition / Symbian^1 devices. Steps mentioned here are no longer needed in v2.5.

SWF2Go Professional 2.0 generated SWF launcher is 100% compatible with latest S60 5th Edition devices (i.e. Nokia N97, 5800XM). We have tested it on these devices.

The output SIS have compatibility UID for S60 3rd Edition devices only. Adding S60 5th Edition platform support manually allows same SIS to be used on both 3rd Edition and 5th Edition devices.

Below are the instructions for making the SIS compatible for S60 5th Edition devices.

You will need MakeSIS.exe and SignSIS.exe from S60 3rd Edition MR (Maintenance Release) SDK. You can search C:\Symbian\ directory for them after installing the SDK.


If you have any questions, you can post them in support forums.

New update of SWF2Go is in the works and will be available soon.